BX: overload alarm with no load?

User avatar
om_tech_support_JT
Posts: 1058
Joined: Fri Mar 12, 2010 2:59 pm
Location: Torrance, CA
Contact:

BX: overload alarm with no load?

Postby om_tech_support_JT » Fri Dec 28, 2012 6:50 pm

Q: I purchased a BX series brushless motor and driver system from you, and I am experiencing overload alarms (2 blinks on the LED), but I have no load connected to the motor. I'm just bench testing with the motor and the driver powered. How can I resolve this issue?

A: An overload alarm on the BX series driver with no load connected to the motor typically means that there's a short in the cable between the motor and the driver. This issue likely happens if you have modified or extended the motor cable yourself incorrectly, which would cause shorts. If your motor still has the standard, factory default pig-tail cable, you can try to connect that directly to the driver (without the modified portion) to see if the alarm goes away. If the alarm goes away, then this shows that the modified portion of the cable is the issue. You should replace that portion of the cable and re-wire. If the alarm does not go away, then that typically means that there are components inside the motor or driver that were damaged due to the modified cable. In this case, you would have to request an RMA from our technical support department so you can send the product in for evaluation. During evaluation, we will investigate the cause of the issue and determine the next action. If you need a replacement during the evaluation period, you do need to purchase an additional unit.

Return to “Speed Control Systems”

Who is online

Users browsing this forum: No registered users and 3 guests