Extending the Oriental Modbus RTU with devices from other manufacturers

Discuss Stepper motors, Drivers, Controllers, GUI's and related Accessories here.
Waschke
Posts: 3
Joined: Thu Jan 12, 2017 2:21 am

Extending the Oriental Modbus RTU with devices from other manufacturers

Postby Waschke » Thu Jan 12, 2017 2:51 am

I'm using a USB/RS485 converter with my PC and have no problems to communicate with the three of my AZD-CD devices over the Modbus RTU. Everything works well. But when I extend the bus with a pressure sensor (Keller PAA33-X) I get the following:
I can address and read out the values of the pressure sensor correctly (Tested with ComTest-Pro), but I get an error from all the Motor Controllers (Upper LED blinks 7 times, MEXE-02 RS485 monitor says Error 84, possible reasons Framing error or BCC error) and I'm no longer able to drive the motors after that.

I use default AZD-CD settings for interfacing (such as Communication TimeOut=0, Error Detection=3, Transmission Waiting Time=3, Silent Interval=0 (automatic), all set with Mexe-02)

Baud Rate = 9600,n,8,1 set correctly for all devices
AZD-CD (1) = ID 1 (set with rotary switch)
AZD-CD (2) = ID 2 (set with rotary switch)
AZD-CD (3) = ID 3 (set with rotary switch)
Pressure Sensor Keller PSS33-X = ID 12 (set with Keller-Software)

What can I do? Thanks for your help!

om_tech_support_JS
Posts: 55
Joined: Tue May 10, 2016 4:48 pm

Re: Extending the Oriental Modbus RTU with devices from other manufacturers

Postby om_tech_support_JS » Tue Jan 17, 2017 12:17 pm

Hi Waschke,

Can you elaborate on your statement of "extending the bus?" In researching the Keller PAA33-X part, the following link states that this product uses RS485 (Digital):
http://www.keller-druck.com/home_e/papr ... _35x_e.asp

Our products use RS485 (Modbus RTU). Therefore, I believe that our product does not accept the output provided from this pressure sensor. You would nee to contact the manufacturer of the sensor to figure out if it can communicate to the Modbus protocol.

Waschke
Posts: 3
Joined: Thu Jan 12, 2017 2:21 am

Re: Extending the Oriental Modbus RTU with devices from other manufacturers

Postby Waschke » Wed Jan 18, 2017 4:44 am

Thanks for the answer!

But you can see on page 8 in:

http://www.keller-druck.com/picts/pdf/e ... ocol_e.pdf

that Keller-Sensors PAA-33X can communicate via Modbus RTU!
If they wouldn't be able to communicate I wouldn't get any values from the sensors, right?

Perhaps you can find a possible reason for my problem when you have a look on this paper?

With best regards,
Detlev Waschke

om_tech_support_JS
Posts: 55
Joined: Tue May 10, 2016 4:48 pm

Re: Extending the Oriental Modbus RTU with devices from other manufacturers

Postby om_tech_support_JS » Wed Jan 18, 2017 2:52 pm

Hi Detlev Waschke,

I understand that you are using the Keller-Sensor PAA-33X to extend the bus, but can you explain the purpose of this sensor being added to the system? What will the extension be used for?

From your description of being able to communicate to either the drivers or the sensor, I suspect that the protocol in the sensor may be interfering with the data into the drives. At the bottom of page 8, there is an "Attention" which states that the error check field byte alignment differs where Modbus is Low:High and the Keller is High:Low. Therefore, I would look at the settings and data structure of the sensor. Another difference that I noticed on page 8 is that the default Parity of the Keller Sensor is none and for our products it is 1: even parity.

Waschke
Posts: 3
Joined: Thu Jan 12, 2017 2:21 am

Re: Extending the Oriental Modbus RTU with devices from other manufacturers

Postby Waschke » Thu Jan 19, 2017 1:49 am

Hi, thanks again for your reply!

All slaves are set to none parity
The CRC alignment is L/H (otherwise I wouldn't get a response from the Keller pressure transmitters, I think)

The purpose of the pressure transmitters is as follows:
Each of the Oriental Motors is driving a piston pump to generate a pressure up to 20 bar. These pressures are to be measured by the transmitters, and I want to regulate the motors with a PID algorithm. For that I have changed the baud rate to 115200 for all the Modbus slaves now.
(As expected the motor controllers still go to the alarm status each time I address a Keller sensor...)

I have contacted a technician from Keller sensors. He thinks that the reason for the problem could be the very short response time of the pressure transmitters. The time between the end of the request and the beginnig of the response is 2.6ms @ 9600 and 0.98ms @115200.

The settings for the Oriental Controllers since the very beginnig of my work are as follows:
Transmission waiting time = "3"
Silent interval = "0" (automatic)

Do you agree with these settings?

Best regards,

Detlev Waschke


Return to “Stepper Motors and Controls”

Who is online

Users browsing this forum: No registered users and 1 guest